XANSYS Forum Index
    Register    

FAQ    Search    Memberlist    Usergroups    SmartFeedSmartFeed    Profile    Log in
Ansys error when using user300 beside another element type
 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    XANSYS Forum Index -> XANSYS
Author Message
mohamed.folifel
User


Joined: 09 Jun 2015
Posts: 4

PostPosted: Wed Jun 10, 2015 12:23 am  Reply with quote

Hi
I am using Ansys Mechanical APDL16 in modelling a concrete beam in which its load is applied through another steel part .I used two different element types the first one is solid185 for the steel part and the second one is user300 for the concrete beam and connection between them using CP.I have this error when solving :

"element 381 references undefined EX of material 1"

I tried to use SOLID185 for both parts and it worked.When i tried a simple code with two elements :one for solid185 and the another is for user300 ,I had the same error.

I need to use user300 as for concrete it is inelastic modelling.

here is the simple code:
Code:

"

/prep7

!adjust user300
ET,1,user300
!Keyopt,1,1,1

!USRELEM, NNODES, NDIM, KeyShape, NREAL, NSAVEVARS, NRSLTVAR, KEYANSMAT, NINTPNTS, KESTRESS, KEYSYM

USRELEM,8,3,Brick,8,168,112,0,8,3,1
USRDOF,define,ux,uy,uz,pres
R, 1, 25000, .2 ,150, .96, .0002, 5 !, 2.4e-9
RMORE, 10, 2

!element type 2
ET,2,SOLID185
MP,EX,2,210000
MP,PRXY,2,.36

ET,3,Plane182

!creating blocks using plane182
tYPE,3
BLC4,0,0,50,50
BLC4,50,0,50,50

!meshing
LSEL,S,LINE,,2,8,2
Lesize,all,50
LSEL,none

LSEL,S,LINE,,1,7,2
Lesize,all,50
LSEL,none

Asel,all
MSHKEY, 1
AMESH,All

!Creating volumes
TYPE,1
EEXTRUDE, PLANE, 1, 1, 50

Esel,All
ASEL,none

Esel,s,elem,,1
EMODIF, all, TYPE, 1 ! change to user300

esel,s,elem,,2
EMODIF, all, TYPE, 2 ! change to SOLID185
Asel,all

/SOLU
!fixed support
nsel,s,loc,x,0
D,All,All

esel,all
asel,all


!apply displacment
nsel,s,loc,x,100
nsel,r,loc,y,0
D,all,ux,1
Esel,all
nsel,all

!hinge support between the two elements
CP,next,Ux,3,8
CP,next,Uy,3,8
CP,next,Uz,3,8


CP,next,Ux,11,16
CP,next,Uy,11,16
CP,next,Uz,11,16


NSUBST,50
NROPT,UNSYM
OUTRES,ALL,1 ! WRITE ALL OUTPUT


SOLVE

FINISH "


I think there is a problem while using another element type with user300 becuase applying one element type user300 for both parts works but when using two element types user300 for each one did not work.


Mohamed Gaber
Student at the Technical University of Dresden
Germany
Back to top
View user's profile Send private message
Martin Liddle
User


Joined: 15 Aug 2008
Posts: 1274
Location: Chesterfield, UK

PostPosted: Wed Jun 10, 2015 12:58 am  Reply with quote

On 10/06/2015 08:23, mohamed.folifel wrote:
Quote:
I am using Ansys Mechanical APDL16 in modelling a concrete beam in which its load is applied through another steel part .I used two different element types the first one is solid185 for the steel part and the second one is user300 for the concrete beam and connection between them using CP.I have this error when solving :

"element 381 references undefined EX of material 1"
Well I can't see any definition of material 1 properties in your code
nor can I see anything to change the assigned material number from the
default of 1 (note that that changing type does not change material
property number). Have you tried listing out the elements (ELIS) to see
what material property number is assigned?

--
Martin Liddle, Tynemouth Computer Services,
Chesterfield, Derbyshire, UK.
www.tynecomp.co.uk

+-------------------------------------------------------------+
| XANSYS web - www.xansys.org/forum |
| The Online Community for users of ANSYS, Inc. Software |
| Hosted by PADT - www.padtinc.com |
| Send administrative requests to xansys-mod@tynecomp.co.uk |
+-------------------------------------------------------------+

Post generated using Mail2Forum (http://www.mail2forum.com)
_________________
Martin Liddle, Tynemouth Computer Services,
Chesterfield, UK.
Back to top
View user's profile Send private message Visit poster's website
mohamed.folifel
User


Joined: 09 Jun 2015
Posts: 4

PostPosted: Wed Jun 10, 2015 2:12 am  Reply with quote

Quote:

nor can I see anything to change the assigned material number from the
default of 1 (note that that changing type does not change material
property number)

Oh,Thanks alot.
I used "MPCHG,.." and it worked.I think you were right "both elements had the same material property".
_________________
Mohamed Gaber
Student at the Technical University of Dresden
Germany
Back to top
View user's profile Send private message
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    XANSYS Forum Index -> XANSYS
All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group

sleek template created by Andrew Charron